Midi Guitar 2 will NOT work with Studio One 6 on an M1 Mac Ventura

Started by lasvideo, December 13, 2022, 11:38:53 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

lasvideo

UPDATE 2 - It seems that SO 6 does not support VST 1 anymore  (on a M1 Mac Mini Ventura) since the only plugins that show up are all AU, VST 2 or VST 3. And since AU apparently doesnt transmit midi data, it seems that Midi Guitar 2 will NOT work with Studio One 6 on an M1 Mac Ventura ( since the only plugs they provide are AU and VST) Dont waste your time.


Update - I am using the ONLY plugin that shows up in SO6 which is Audio Unit (which apparently doesnt send Midi data). I installed the VST plugin in the appropriate folder as well, but it does NOT show up in the plugin list.
I am trying to get Midi Guitar 2 to work in SO 6. I have followed the following steps and even through I get a signal from the guitar on TRK 1, and the Midi Guitar 2 configuration screen shows that signal is nicely being converted to midi. But it is NOT being routed to TRK 2 and therefore the synth instrument is not getting triggered. Here are the steps I followed which worked for the OP. "On the Home Page click New and choose Record and Mix for a new blank song.




As per the article: Add a mono audio track for your guitar, and assign its input to your guitar's audio interface input. Set the track's input Monitor to on.
Check you have input before the next step, may save time later and confirms that you do have input, the meter will also confirm this, but once you add the MG2 plugin it goes silent unless you use MG2 as the instrument and we are not doing that, a different tutorial.
Insert the Jam Origin MIDI Guitar 2 plug-in into the guitar track.
You will find this in the browser under Effects - Vendor - Jam Origin.
Also under Type - AudioUnits.
Just drag the icon across onto the left hand box on the guitar track you just created.
Silence! The audio is not passing through now, but don't worry we want the Instrument sound.
Create an instrument track with your instrument of choice. Mai Tai is my go-to for MIDI guitar, but any VST3 or VST2 instrument I've used so far works.
For me Presence or Ample Bass and for Mike Mojito.
Vital - Do this by going to Instruments in the browser and drag the icon of your choice into the Track window, not the Mixer window as this does something different and will be investigated later.
This is where it gets tricky as the article says : Assign the instrument track input to MIDIGuitar2-64bit (fig. 1).
It leaves vital info out so follow what I did and hopefully it will work for you.
Things have changed in Studio One 6 and if you have followed me exactly you will see your guitar track and instrument in the Track Window in Normal View, I recommend that you also open the Mixer Window .
In Studio One 5 I would normally click the 'i' above the tracks on the left to open Information and use this to assign the input, this is now missing in Studio One 6 so what do we do next!
Change the Track view from Normal to Large and you will see the all the options, it will show All Inputs the second one down, we need MG2 as input,. The problem is this does not work for me so I had to try something else.
Open up Preferences, I click I/O top left of the Mixer Panel and you get Song Setup, click Preferences bottom left and then External Devices.
Now we need to add MG2 as an External Device so click Add.
A new window will open up to add a New Keyboard.
I entered 'Jam Origin' as the Manufacturer and 'MIDI Guitar 2 Ext Inst' in Device Name.
In the Receive From further down choose 'MIDI Guitar # 'x' out', I was showing #2 as I have already done this once.
Go back to the inputs on the Instrument Track and try again, you will now see 'MIDI Guitar 2 Ext Inst' as an input option.
Choose this and it all worked for me.
Make sure that the Loudspeaker icons are activated to hear everything.
Has anyone been successful?

lasvideo

The problem is with the Midi Guitar 2 VST2 plugin. It ONLY shows up when I boot Studio One 6 in Rosetta mode. When I boot it up normally the VST is not there. And their AU version is useless on the M1 since it doesnt transmit midi data. So "bye bye" Midi Guitar 2. Such a shame.


Vaultnaemsae

I have avoided macOS Ventura so far as I don't want to test on my primary device and my older backup Macbook can only go as far as Monterey. But based on what I read above, wouldn't it be simple enough just to use the MG2 application with its virtual MIDI port as the MIDI source in the DAW? Assuming the standalone app works...can't imagine why it wouldn't...

FWIW, I use MG2 with virtually no issues on macOS Monterey in Ableton Live 11 and various other DAWs. And the journey from Big Sur to Monterey was completely smooth. Nothing broke.
Vaultnaemsae's SoundCloud:
https://soundcloud.com/vaultnaemsae

lasvideo

Yes, the standalone works fine.
I am not familiar with  how to "use the MG2 application with its virtual MIDI port as the MIDI source in the DAW" with Studio One. Would you explain exactly how to achieve this please. To clarify my goal , I want to use Midi Guitar 2 with Studio One 6 when I do live tracking of my guitar. Which is being recorded simultaneously as I listen to the other tracks. As far as I know, the plugin is necessary to do this process. And Rosetta really cripples the speed of SO on my M1 Mac Mini. I have other options now I am aware of its problem.

lasvideo

I did fine more info about using the stand alone with a DAW. They suggest the plugin is the better way to go due to latency and other issues.
You cannot view this attachment.

Vaultnaemsae

You'd run both apps simultaneously and set the MIDI IN of your MIDI track in Studio One (SO) to "MIDI Guitar Virtual MIDI Output" or whatever the exact created MIDI output name from MG2 is.

Latency is negligible, let alone perceptible. I believe Jam Origin's (JO) advice may be more about tidy workflow housekeeping than actual latency.


BTW, I've seen your post on the issue at the Jam Origin forum and what the three responders there told you is correct though you seem to have conflated the AUv2 MIDI "not transmitting" thing with the AUv2 "not working" thing.

You do not need the MG2 AUv2 to "send MIDI" invisibly (as the VST2 version does) because the AUv2 creates its own MIDI port that the DAW sees as a virtual "external" MIDI device. Select that as your source and you should be good to go -- no VST2 required. This is how it works in Live 11 and Logic Pro so I imagine SO would be the same.

I initially avoided replying because I don't use SO and wasn't prepared to install/test it and didn't want to lead you astray but the poster Catwizud on the JO forum has checked for you and confirms the AUv2 functions as expected.

Specific to your issue, I suspect that you may have to activate a MIDI port in the MIDI settings of SO...just an educated guess. I hope it's a simple solution like this.

FWIW, I have been running MG2 AUv2 in Ableton Live 11 (M1 native) and it smokes everything I throw at it at a 64 sample buffer. Running under Rosetta 2 works just fine too and makes routing slightly more reliable/easier as the MG2 MIDI port numbers don't accumulate every time you open a new instance of the plugin.
Vaultnaemsae's SoundCloud:
https://soundcloud.com/vaultnaemsae

lasvideo

Thanks. Yes, I just got it to work. In Studio One 6 I dragged the instrument (Analog Lab 5) to the track area instead of the left (mixer area) and that fixed it.