Author Topic: FENDER TRIPLEPLAY OEM Battery failing. WAS USER ERROR: Everything is fine now  (Read 376 times)

0 Members and 1 Guest are viewing this topic.

Offline plethoraguy

Lately I have been having trouble with my tripleplay setup (Previously functioning patches in my Muse Receptor no longer playing, etc)  and I initially assumed it had something to do with the new software/firmware.     I struggled through for a while but I finally noticed the red battery light would start blinking within just a couple of minutes of powering up (again, I have the Fender with tripleplay built in, not the front mounted unit).   Anyway I take this to mean my battery is no longer holding a charge.    I've treated this guitar with nothing but the utmost respect and kindness (no overnights in a frozen garage, or baked in a sunny car, etc).      What can I do to get the battery replaced on this thing?  I have a paid gig tonight and I guess I'll just have to go without my lush synth additions.   
« Last Edit: March 29, 2017, 11:02:10 AM by plethoraguy »

Offline Elantric

Re: FENDER TRIPLEPLAY OEM Battery failing.
« Reply #1 on: March 11, 2017, 04:29:51 PM »
contact Fender Support asap

Fender Customer service in Arizona
Fender Musical Instruments Corporation
Attn: Consumer Relations Dept.
17600 N. Perimeter Drive, Suite 100
Scottsdale, AZ 85255
Telephone: (480) 596-7195
Fax: (480) 367-5262
E-mail: consumerrelations@fender.com

Offline plethoraguy

Re: FENDER TRIPLEPLAY OEM Battery failing.
« Reply #2 on: March 14, 2017, 10:45:48 AM »
Thanks for the reply...  I am somewhat befuddled because it seems to be working fine again...  perhaps the issue was with my charger?    I am trying to sort it out.  There are no known battery issues with the new software/firmware are there?    The weirdness occurred right after I upgraded but I think maybe it was just a coincidence. 
« Last Edit: March 14, 2017, 12:53:21 PM by plethoraguy »

Offline plethoraguy

Re: FENDER TRIPLEPLAY OEM Battery failing.
« Reply #3 on: March 27, 2017, 12:27:58 PM »
Just a follow up.    Everything is back to normal, I think my wall charger maybe was having an issue, but even that works fine now.
Nothing to see here...   move along, move along.

Offline admsustainiac

Re: FENDER TRIPLEPLAY OEM Battery failing.
« Reply #4 on: March 27, 2017, 12:47:55 PM »
I find its best to use a USB Charger that provides 5VDC @ 1000mA (1A) output minimum


« Last Edit: March 27, 2017, 01:23:29 PM by admsustainiac »

Offline plethoraguy

Thanks for the info. I am using the one that came with my FTP which has those same specs.   Still don't know exactly what was going on but it's working great again, without any definitive correction on my part, so I have changed the Thread title to say that that the problem is resolved.

 

Blog