Author Topic: GT1 Tone Studio Librarian not working correctly on Mac  (Read 814 times)

0 Members and 1 Guest are viewing this topic.

Offline Synthetica

GT1 Tone Studio Librarian not working correctly on Mac
« on: December 01, 2016, 08:12:39 PM »
It will not allow you to copy and paste patches as stated in the manual, you can import , export, backup, create and apply livesets, but when i tried to create a custom liveset it willl not allow you to copy and paste any patches into the custom set. You can also not drag any patches onto the the current set, only thing you can do is apply live set and it always puts every live set at the top at patch #1 overwriting any others. I realize its version 1 but this needs to be fixed.

 

Offline Elantric

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #1 on: December 01, 2016, 11:16:45 PM »
Quote
It will not allow you to copy and paste patches as stated in the manual, you can import , export, backup, create and apply livesets, but when i tried to create a custom liveset it willl not allow you to copy and paste any patches into the custom set. You can also not drag any patches onto the the current set, only thing you can do is apply live set and it always puts every live set at the top at patch #1 overwriting any others. I realize its version 1 but this needs to be fixed.

Or do what I do, Research the Operating system compatibility requirements for the Roland/Boss applications you wish to use.

I followed the Roland / Boss warning posted on their Support page back in October 2016 to avoid updating your Mac to "macOS" 10.12

I use BTS for GT-1 100% working fine on OSX Yosemite and Mavericks


https://www.boss.info/global/support/support_news/1609211012b/
« Last Edit: December 02, 2016, 01:06:54 AM by Elantric »

Offline Synthetica

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #2 on: December 02, 2016, 10:02:01 AM »
Ahh thanks for the update, that would explain the problem, I have the latest Mac OS Sierra installed. Didn't think about that one. Hopefully there will be an update to tone studio in the near future.



Offline mooncaine

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #3 on: December 31, 2016, 11:46:17 AM »
I just got a GT-1, and I'm using Yosemite 10.10.5. I experience most of the probs Synthetica described. I am able to create a custom LiveSet by dragging and dropping. Copy doesn't work, nor does Paste. The only way I've found to get a single patch from computer to GT is to make a LiveSet, put it in the set, and apply the set. As Synthetica describes, the LiveSet always inserts starting at patch #1 on the GT.

I don't see any of these as big problems, but wanted to share my experience for the sake of comparison.

It'd be great if Copy and Paste worked, because that's way healthier for my hands than dragging and dropping, but it's not a huge bummer.

Offline mooncaine

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #4 on: January 01, 2017, 09:19:33 PM »
But, hey, good news: I can copy a patch, in Librarian view, by alt-dragging it!

Offline Funky

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #5 on: January 15, 2017, 03:12:50 PM »
@Synthetica : I hope so too...I used a GT-001 for over a year, with Tone Central, just for practice at home. I sold my 001, and bought a GT-1 because of the pedals. Very happy with it, but it is very annoying that I can't make any Livesets (or, add the patches I want). I never really used those with my GT-001, and installed Sierra. So now I'll have to wait for a patch to use the Livesets...

Offline AnalogNerd

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #6 on: January 15, 2017, 09:31:57 PM »
Does it normally take Boss so long to release updates? The last news on their site regarding Sierra was from Oct 7th, over 3 months ago. And it's not like 10.12 was a surprise to anyone... granted, the GT-1 is brand new, but still...

Online admsustainiac

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #7 on: January 15, 2017, 11:49:54 PM »
Yes, I don't expect a BTS update until April 2017

Quote
And it's not like 10.12 was a surprise to anyone... granted

But success with Audio / MIDI requires a stable operating system that can provide lowest latency for real time processing  -

The macOS Sierra  new features:  SIRI Integration, Apple Watch auto unlock, all conspire to thwart those tasks

https://pdf.wondershare.com/pdf-knowledge/macos-sierra-vs-el-capitan.html
« Last Edit: January 16, 2017, 12:42:24 PM by admsustainiac »

Offline mooncaine

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #8 on: January 16, 2017, 12:28:32 PM »
SO, my workaround for this is to always make a blank liveset, drag the patches you want into it, and apply it. That's writing all the user patches. It feels silly, but it's predictable. I get the patches on the numbers that I wanted them on.

Still not sure it's the best workaround for Mac users. It's just what I've discovered on a single Mac.

Offline AnalogNerd

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #9 on: January 17, 2017, 12:01:59 AM »
Yes, I don't expect a BTS update until April 2017

But success with Audio / MIDI requires a stable operating system that can provide lowest latency for real time processing  -

The macOS Sierra  new features:  SIRI Integration, Apple Watch auto unlock, all conspire to thwart those tasks

https://pdf.wondershare.com/pdf-knowledge/macos-sierra-vs-el-capitan.html

Understood; I hadn't considered all the implications on audio processing.  I figured it was just another release, since they're done pretty regularly. Just want to get the most out of my new GT-1. Things have changed quite a bit since I last dipped my toes into effects- the only pedals I've owned up to now are a early 90's Rat and a wah!

Offline mooncaine

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #10 on: February 28, 2017, 09:53:35 AM »
I could have used this today. It would have really helped me get something in place for a band rehearsal right after work.

I am not enthused about buying a piece of new gear, less than 4 months old, to find it doesn't work with the latest Mac operating system.

 :(

Tick tock, Roland, tick tock.
« Last Edit: March 13, 2017, 11:24:05 PM by mooncaine »

Offline drbill

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #11 on: February 28, 2017, 10:11:10 AM »
Apple OS updates are done in complete secrecy, with no outside knowledge of changes until they are released, so Roland's delay is completely excusable. Oh, wait....
GP-10, KPA
BM i2.13p, '76 Les Paul Deluxe w/GK-3, MiM RRS, Ibanez RG420GK, Charvel strat copy w/GK-2a, FTP

Online admsustainiac

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #12 on: February 28, 2017, 10:14:38 AM »
Bulk of my Music gear being incompatible with latest mac OS release each fall is a common occurrence for past few years

I've grown used to it and stick with Yosemite to remain productive with creating music

Offline drbill

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #13 on: February 28, 2017, 10:19:10 AM »
Bulk of my Music gear being incompatible with latest mac OS release each fall is a common occurrence for past few years

I've grown used to it and stick with Yosemite to remain productive with creating music

This is not an option for anyone that's bought a new computer in the last several months. Mac OS betas begin to be available in June and the OS updates are released 3-4 months later. A 6 month wait after the OS is released is inexcusable, really.

If they're waiting for an Adobe AIR update, that's their fault for choosing that stupid bloatware for a platform.
« Last Edit: February 28, 2017, 10:21:19 AM by drbill »
GP-10, KPA
BM i2.13p, '76 Les Paul Deluxe w/GK-3, MiM RRS, Ibanez RG420GK, Charvel strat copy w/GK-2a, FTP

Offline AnalogNerd

Re: GT1 Tone Studio Librarian not working correctly on Mac
« Reply #14 on: March 19, 2017, 07:40:24 AM »
This is not an option for anyone that's bought a new computer in the last several months. Mac OS betas begin to be available in June and the OS updates are released 3-4 months later. A 6 month wait after the OS is released is inexcusable, really.

If they're waiting for an Adobe AIR update, that's their fault for choosing that stupid bloatware for a platform.

This was exactly my problem. Bought a new Mac ~6 months ago and was surprised when I couldn't use it to run the Boss software. Oh well, it's fixed now...